Как загрузить 1С с флешки

Иногда возникают ситуации, когда необходимо сделать копию информационной базы 1С 8.3 и записать ее на флеш-носитель, чтобы перенести базу на другой компьютер, сделать копию при переустановке операционной системы или просто для ее хранения на флешке, чтобы более обезопасить себя.

Как выгрузить базу 1С 8.3 на флешку

Для выполнения этого действия зайдем в Конфигуратор нашей информационной базы (ИБ). В меню Администрирование выберем пункт Выгрузить информационную базу.

В окне указываем путь выгрузки и задаем имя файла. Файл выгружается в формате *.dt — это архивная копия базы в формате 1С. Далее у нас два варианта.

Первый вариант — мы можем при указании пути файла сразу задать, что мы выгружаем данные на флешку. При нажатии кнопки Сохранить будет произведена выгрузка непосредственно туда.

Второй вариант — мы выгрузим наши данные в папку компьютера, например в папку Архив 1С, а уже потом перенесем ее на флешку. В этом случае, мы указываем путь к нашей архивной папке (или другому месту выгрузки).

По окончании выгрузки программа 1С 8.3 выдаст сообщение.

После чего, перейдем в нашу папку с сохраненным файлом. В нашем примере Мой компьютер — Диск С — Архив 1С.

Для того чтобы перенести файл нашей архивной копии на флешку, нажмем на нем правой кнопкой мышки и открыв пункт меню Отправить выберем наш съемный носитель, в нашем случае он называется — Флешка (Н:).

Файл будет скопирован на флеш-носитель.

Загрузка базы 1С 8.3 с флешки через Конфигуратор

Загрузка файла, выгруженного через Конфигуратор производится также через пункт меню Администрирование — Загрузить информационную базу.

В открывшемся окне, переходим к нашей флешке и выбираем сохраненный файл. В нашем примере 1Cv8.

Нажимаем кнопку Открыть и ждем окончания загрузки.

Как скачать базу 1С 8.3 на флешку

Иногда возникают ситуации, когда требуется просто перенести на флешку (или съемный диск) информационную базу 1С 8.3 и подключить ее на другом компьютере, например для просмотра данных при проведении ревизии вышестоящей организацией, проверки контролирующими органами, если есть необходимость воспользоваться базой.

Иногда требуется перенести базу 1С 8.3 на съемный диск для работы не в офисе, а дома. Хотя вариант работы с информацией с флешки небезопасен, неправильное извлечение флешки или сбой может привести к потере данных или сбою в работе программы 1С. Альтернатива такой работы — это работа в 1С в облаке .

Но все же рассмотрим этот вариант. Для этого нам нужно знать, где располагается наша база 1С 8.3. Это видно в нижней части окна запуска программы. Для отображения этой информации необходимо выделить название базы.

Найдем папку с нашей информационной базой.

Перед тем как скопировать ее на флешку, надо убедиться, что информация помещается на флешку, для этого нажмем правой кнопкой мышки на папке с ИБ, откроем пункт меню Свойства и посмотрим ее объем.

Далее, нажав на папке правой кнопкой мышки выбираем пункт меню Отправить и выбираем наш съемный носитель, в нашем примере Флешка (Н:).

Наша папка с информационной базой 1С 8.3 отправлена на флешку. Дожидаемся окончания копирования и извлекаем флешку в безопасном режиме.

Как загрузить базу в 1С 8.3 с флешки

Для подключения и просмотра информационной базы 1С 8.3 с флешки в окне запуска программы 1С Предприятие нажмем кнопку Добавить.

В окне добавления информационной базы установим переключатель в положение Добавление в список существующей информационной базы.

Нажав кнопку Далее, пишем название нашей базы и указываем путь к ней.

В нашем случае она размещена на Флешке (Н:). Нажимаем кнопку Выбор папки.

Указываем параметры запуска (можно оставить по умолчанию).

И нажимаем кнопку Готово и наша информационная база 1С 8.3, установленная с флешки, готова к использованию.

Напомним о том, что нельзя извлекать флешку пока открыта программа 1С, иначе возможно ее повреждение и база может впоследствии не запуститься.

См. также:

  • Как перенести 1С 8.3 на другой компьютер с сохранением лицензии
  • Как выгрузить документ, отчет из 1С 8.3 в Excel
  • Резервное копирование 1С 8.3 Бухгалтерия 3.0
  • Как создать информационную базу в 1С 8.3

Если Вы еще не являетесь подписчиком системы БухЭксперт8:

Активировать демо-доступ бесплатно →

или

Оформить подписку на Рубрикатор →

После оформления подписки вам станут доступны все материалы по 1С Бухгалтерия, записи поддерживающих эфиров и вы сможете задавать любые вопросы по 1С.

Помогла статья?

Получите еще секретный бонус и полный доступ к справочной системе БухЭксперт8 на 14 дней бесплатно

С появлением возможности выгружать и загружать данные на сайт жизнь интернет-магазинов стала много проще. Как легко теперь мигрировать e-commerce с площадки на площадку со своими товарами.

Экономия ценного времени – вот почему необходимо настроить всевозможные экспорты популярных форматов, в том числе и YML. Для тех, кто вообще не в теме, начнем с азов.

Формат YML

Яндексовский изотоп формата XML. Это широко распространенный язык разметки, понятный сейчас практически любой системе. С его помощью информация обретает структуру. По сути, он обрамляет данные в теги, которые описывают, где и как должны располагаться эти данные, что они означают и вообще, что угодно. А самое прекрасное – это возможность создавать собственные теги, чем и воспользовались в Яндексе и фактически создали свой стандарт разметки, удобный для перемещения товаров из магазинов на их Маркет и обратно, а также между всяческими сайтами. Надо сказать, это очень полюбилось пользователям, и они охотно пользуются возможностями YML.

Для чего нужна YML-выгрузка

Как вы уже поняли, основная функция такого экспорта – это его последующая передача на другие сервисы и площадки, в первую очередь на Яндекс.Маркет.
Представьте себе, что в Маркет люди присылали бы файлы каждый в том виде, в котором он его ведёт: в таблице Excel со своими заголовками, кто-то соблюдая форматы ячеек, а кто-то нет, может, и вообще не в Экселе… Сколько лет понадобилось бы специалистам, чтобы разобраться в этом хаосе. К счастью, есть стандартизация, и все всё загружают красиво, в унифицированном виде, и получают тоже красиво, именно так, как хотели (название категорий, цена и т.д. – всё своё). Вы, конечно, можете загружать и табличные форматы, но придётся сильно ограничить свою фантазию.

Плюсы YML очевидны:

  • Вы не добавляете товары вручную
  • Не нужно нанимать человека или тратить время на размещение всей информации о товарных позициях
  • Для разных источников можно использовать один и тот же формат. Уже имея YML-документ, вам зачастую даже не понадобиться создавать XML
  • Интеграция со многими рекламными системами, агрегаторами также пройдёт безболезненно для вас
  • Генерируя файл YML-экспорта на сайте, можно забыть и про отслеживание и ручное обновление прайсов. В OkayCMS этот функционал уже реализован в Pro-версии и даже в Lite (где вы видели вообще такое?)! Воспользоваться им можно просто из админпанели, выбрав все или определенные товары. Фид (сформированный файл) будет доступен по адресу: https://demookay.com/yandex.xml

Самый эффективный движок для быстрого старта вашего бизнеса в интернете. Более 4000 работающих интернет-магазинов.

Создай свой магазин!

С помощью выгрузки yml-документов можно также хранить свою информацию, делая своеобразные бэкапы. Если какой-то интернет-источник вдруг прекратит свою работу, у вас останется готовый документ, который также легко потом будет восстановить и преобразовать.

YML-ками удобно обмениваться с партнерами прайс-листами, интегрируя их в свою систему. Здесь такой формат хорош тем, что не нужно ничего скачивать, путаться в нескольких документах или ждать, когда вам что-то вышлют на почту, достаточно 1 раз получить ссылку.

Как выгрузить товары с сайта в Яндекс.Маркет

Процедура экспорта для версий 1*описана . После обновления система усовершенствовалась в плане экспорта, но логика осталась схожей и по-прежнему интуитивно понятной. В админпанели заходите на вкладочку с товарами и справа нажимаете на значок XML напротив товара, который нуждается в выгрузке.
Вы также можете фильтром отыскать те позиции, которые уже есть на Маркете или наоборот.
Можно комбинировать бренды и категории в фильтрах с участием в Маркете.
Все выбранные товары пойдут в фид. Чтобы просмотреть его, к своему домену добавляете /yandex.xml Эту ссылочку просто копируете и вставляете туда, куда вас просит ЯндексМаркет. Вот и всё, совсем не больно!
Если вы не являетесь счастливым обладателем ОкаиЦМС, а несчастный пользователь какой-то другой системы, то ещё не поздно одуматься 🙂

Тогда лучшим решением будет обратиться к специалисту или же, чётко выполнив обучающие рекомендации Яндекса, попробовать загрузить своё творение на их площадку.

Пример YML

В справке у Яндекса есть бездушный шаблон YML-файла. Но мы не жадные, можем поделиться своим демо-документом для понимания, как должен выглядеть красивый и правильный сгенерированный файл выгрузки:https://demookay.com/yandex.xml

Какие могут быть ошибки в YML

Яндекс даёт довольно подробные описания и требований, и самих возможных ошибок. Ознакомиться с ними можно в справке. Они также вряд ли откажут вам в поддержке, но будьте благоразумны и ознакомьтесь сначала с документацией.
Владельцы сайтов Окай могут не задумываться над ошибками, т.к. выгрузка YML автоматическая, но перечислим основные моменты, в которых эти ошибки могут возникать:

  • несоответствие спецификациям XML. Проверить можно, поменяв расширение на .xml и посмотреть в браузере либо прогнать через валидатор;
  • несоблюдение требований к формату YML (элементы используются неправильно или не в том порядке, есть пустые, отсутствуют обязательные, встречаются недопустимые символы);
  • не та кодировка. Принимаются UTF-8 и windows-1251;
  • повторяются id (он на то и айди, чтобы быть уникальным);
  • проблемы с URL (ведут на несуществующий файл, имеют кириллические символы, пробелы). Нужно обратить внимание на протокол и www
    расположен на поддомене или на другом сайте.

Вообще и в общем, нужно в первую очередь соблюдать условия размещения своего магазина на площадке Яндекса. Не имея всего, что требует соглашение, стоит ли заморачиваться с составлением yml-прайса для Маркета.

Бонус – нестандартное использование разметки YML

Яндекс подарил людям прекрасную возможность пользоваться Вебмастером и даже с его помощью бесплатно улучшить отображение своих товарных страниц в результатах поиска. Загрузив YML-файл (вставив ссылку и нажав «Добавить») вот сюда
обновляете статус и после проверки нажимаете зеленую галочку, если она прошла успешно. Вы также сможете узнать причину, если проверка покажет ошибку. Результатом всех мучений будут привлекательные сниппеты с ценой в выдаче Яндекса.

Итак, мы узнали, что YML-выгрузка – это во всех отношениях полезная штука. Не отказывайтесь от столь удобного функционала и не забывайте, что у нас ещё много крутых фишек!

Иногда возникают ситуации, когда необходимо сделать копию информационной базы 1С 8.3 и записать ее на флеш-носитель, чтобы перенести базу на другой компьютер, сделать копию при переустановке операционной системы или просто для ее хранения на флешке, чтобы более обезопасить себя.

Как выгрузить базу из 1С

Для выгрузки базы 1С выполним следующие действия:

  1. Заходим в программу в режиме «Конфигуратор”:
  2. В конфигураторе заходим в меню «Администрирование – Выгрузить информационную базу”:

Перед выгрузкой нужно обязательно попросить всех пользователей выйти из базы. Иначе выйдет сообщение «Ошибка исключительной блокировки информационной базы”:

Наша команда предоставляет услуги по консультированию, настройке и внедрению 1С.
Связаться с нами можно по телефону +7 499 350 29 00.
Услуги и цены можно увидеть по .
Будем рады помочь Вам!

  1. Далее указываем имя файла и папку для хранения файла (на флешку или жесткий диск), нажимаем «Сохранить”:
  2. Запустится процедура создания копии, если все пройдет хорошо, выйдет сообщение о завершении:

Как загрузить информационную базу 1С

Важно помнить, что база, в которую загружается файл dt, полностью заменяется на данные из этого файла. Поэтому эту операцию нужно выполнять с осторожностью.

  1. Открываем 1С в режиме «Конфигуратор” и выбираем меню «Администрирование — Загрузить информационную базу”:
  2. Находим папку с копией базы, выделяем нужную копию и нажимаем «Открыть”:

После этого выйдет предупреждение, нажимаем «Да”:

Через некоторое время база будет загружена.

Как удалить базу 1С с компьютера

Часто, после выгрузки на флешку, нужно удалить все следы базы данных с компьютера.

Сделать это очень просто — нужно удалить папку базы данных, путь к которой можно узнать в стартовом окне программы:

В нашем случае нужно удалить папку «Бухгалтерия предприятия». Удалять файл лучше всего комбинацией shift+del, так вы удалите файлы минуя корзину.

После удаления попробуйте запустить базу. Должно выйти сообщение «База данных не найдена».

ВНИМАНИЕ!!! Перед удалением ОБЯЗАТЕЛЬНО попробуйте загрузить сделанную копию базы и проверить её работоспособность.

1С Конвертация данных 2.0¶

Конвертация данных. ПКО ПослеЗагрузкиОбъекта не срабатывает¶

Обработчики вызываются из правил в конфигурации приемника. Нужно в базу-приемник загрузить правила конвертации объектов из архива содержащего файл CorrespondentExchangeRules.XML.

Дополнительно (не проверено)
Проверить какой стоит режим совместимости в правилах.
1. если 2.0 и ниже тогда код обработчиков после загрузки в конфигурации в соотв. обработках (см. модуль менеджера плана обмена там прописано название обработок).
2. если ничего не указано то код обработчиков после загрузки вызывается из правил, которые находятся в конф. приемнике — правила конфигурации корреспондента. Т.е. загружать надо не только в конфигурацию источник, но и в конф. приемник в правила конвертации корреспондента.
П.С после загрузки правил не забываем перезапускать 1с.

Передача документа со строками с уже ранее загруженной номенклатурой (без создания новой)¶

  1. В ПКС для номенклатуры в обработчике «ПередВыгрузкойСвойства» указываем:
    ВыгрузитьОбъект = ложь; //будет выгружена только ссылка
  2. В ПКО в обработчике ПослеЗагрузкиОбъекта проверяем на корректную ссылку
    Если не Отказ Тогда //756 МассивСтрок = Новый массив; Для Каждого СтрокаТЧ из Объект.Товары Цикл Если не ЗначениеЗаполнено(СтрокаТЧ.Номенклатура.ВерсияДанных) Тогда // проверка на корректную ссылку! МассивСтрок.Добавить(СтрокаТЧ); КонецЕсли; КонецЦикла; Для Каждого СтрокаДляУдаления из МассивСтрок Цикл Объект.Товары.Удалить(СтрокаДляУдаления); КонецЦикла; КонецЕсли;

v8: Инкрементальный экспорт с ипользованием Конвертации Данных v8¶

Описано, как используя конфигурацию «Конвертация Данных» (платформа v8) настроить выгрузку лишь тех данных, которые были изменены со времени последней выгрузки. Автор статьи: Negro | Редакторы: Макаров
Последняя редакция №7 от 23.05.08 | История
URL: http://kb.mista.ru/article.php?id=356

Ключевые слова: конвертация, обмен, данные, выгрузка, экспорт, измененные

Бывают задачи, когда нужно наладить обмен данными между конфигурациями разной структуры. УРБД здесь не поможет. Единственно приемлемый по оперативности вариант — использование конфигурации «Конвертация данных» платформы 8.0. Но, увы, выгрузка данных не учитывает, изменялся ли данный объект с момента последней выгрузки или — нет. Выгружает все данные за жестко назначенный период. Иногда это очень большой массив. Хотелось сделать выгрузку инкрементальной. Оказывается это возможно. Нужно лишь сделать следующее:

1. Создать в конфигурации План обмена (для рассматриваемого примера — ПланОбмена1).
2. В режиме 1С:Предприятия завести в план обмена новый узел (для примера узел с кодом «00001»).
3. В правиле выгрузки данных (для примера — для документа Документ1) в качестве способа выгрузки выставить значение «Произвольный алгоритм».
4. В поле обработчика события «Перед обработкой» вписать код наподобие следующего:

Узел = ПланыОбмена.ПланОбмена1.НайтиПоКоду(«00001»); Выборка = ПланыОбмена.ВыбратьИзменения(Узел, 1); ВыборкаДанных = Новый Массив; Пока Выборка.Следующий() Цикл Данные = Выборка.Получить(); Если Данные.Метаданные().Имя = «Документ1» Тогда ВыборкаДанных.Добавить(Данные.Ссылка); ПланыОбмена.УдалитьРегистрациюИзменений(Узел, Данные.Ссылка); КонецЕсли; КонецЦикла;

И, собственно, все. На вашей (вернее — моей 🙂 совести остается лишь слепая уверенность в том, что пакет выгруженных данных обязательно дойдет до адресата и без ошибок загрузится в базу. Именно поэтому я спокойненько удаляю сведения о выгружаемом объекте из регистра изменений. Можно конечно сделать пакет подтверждения импорта, но это уже другая история… Т.о. описанное решение является гибридным (конвертация данных + использование планов обмена).

А лучше так:

В конвертации, в обработчике события «Перед выгрузкой данных» :

Узел = ПланыОбмена.ВыгрузкаВПроизводство.НайтиПоКоду(«00001»); ВыборкаИзменений = ПланыОбмена.ВыбратьИзменения(Узел, 1); Выборка=Новый Массив; Пока ВыборкаИзменений.Следующий() Цикл Данные=ВыборкаИзменений.Получить(); Выборка.Добавить(Данные); КонецЦикла; Параметры.Вставить(«Выборка»,Выборка); Параметры.Вставить(«Узел»,Узел);

Выборку изменений перевожу в масив, потому что с выборкой почему-то не работает, а с масивом нет проблем.

В поле обработчика события «Перед обработкой»:

Выборка=Параметры.Выборка; Узел=Параметры.Узел; ВыборкаДанных = Новый Массив; Для Каждого ТекВыборка из Выборка Цикл Данные = ТекВыборка; Если Данные.Метаданные().Имя = «Документ1» Тогда ВыборкаДанных.Добавить(Данные.Ссылка); ПланыОбмена.УдалитьРегистрациюИзменений(Узел, Данные.Ссылка); КонецЕсли; КонецЦикла;