Просклонять 1С 8

В соответствии с правилами русского языка, ряд фамилий не подлежит склонению (написание производится только в именительном падеже). При оформлении приказов, распоряжений, актов и других документов, в них указываются данные о сотрудниках (ФИО), в некоторых из них данные подлежат склонению.

Например, в печатной форме КО-2 Расходный кассовый ордер, данные о сотруднике указываются в дательном падеже (выдать кому?)

В большинстве случаев в конфигурации «1С:Бухгалтерия 8 для Казахстана», ред. 3.0 происходит автоматический контроль корректности склонения данных лица в соответствии с общеустановленными правилами.

Однако некоторое склонение фамилий может вызывать затруднение. Для принудительного отключения склонения данных ФИО лица, предусмотрена специализированная настройка. Настройка расположена в карточке физического лица, по ссылке История изменения ФИО.

В открывшемся окне отражаются сведения о данных физического лица и история изменения этих данных. Для запрета склонения текущей фамилии лицу, в окне необходимо установить признак Не склонять фамилию.

При установке данного признака, во всех формах и документах фамилия лица подлежи отражению в именительном падеже (без склонения).

Полезно

Пример приведен справочно. В данном случае фамилия подлежит склонению.

  • Как в программе 1С отразить для физического лица статус пенсионера по выслуге лет?;
  • Как в конфигурации назначить ОПВ работнику-инвалиду I или II группы с бессрочным сроком действия справки?

Библиотека вместе с файлом MANIFEST.xml (регистр имеет значение) должна быть упакована в ZIP архив и добавлена в виде двоичных данных в макет обработки с именем «AddInWindows32»

При работе в тонком и web клиенте обязательно использования метода УстановитьВнешнююКомпоненту():

Пример процедуры установки внешнего компонента:

&НаКлиенте // Процедура должна вызываться лишь один раз при первичной установке компонента, либо при обновлении его версии Процедура УстановитьКомпонент() АдресАрхиваКомпонента = «Обработка.МИКО_ПанельТелефонииДляCRM.Макет.AddInWindows32»; Попытка УстановитьВнешнююКомпоненту(АдресАрхиваКомпонента); Исключение Сообщить(«Не удалось устанвить внешнюю компоненту.»); КонецПопытки; КонецПроцедуры

При успешном выполнении метода УстановитьВнешнююКомпоненту файлы компонента будут распакованы в каталоги:

Для подключения компонента можно использовать следующую процедуру:

&НаКлиенте Процедура Инициализаровать() АдресАрхиваКомпонента = «Обработка.МИКО_ПанельТелефонииДляCRM.Макет.AddInWindows32″; Если ПодключитьВнешнююКомпоненту(ПутьКМакету,»Comp»,ТипВнешнейКомпоненты.Native) Тогда Компонент = Новый («AddIn.Comp.MikoAjam»); Иначе СообщитьОтладочнуюИнформацию(«Не удалось подключить внешнюю компоненту»,»»); КонецЕсли; КонецПроцедуры

При работе в 1С пользователь сталкивается с вопросом склонения фамилии или должности сотрудника в печатных формах документов, то есть с ситуацией, когда надо выполнить склонение фамилий по падежам.

Для склонения ФИО в программах 1С предусмотрена внешняя компонента – NameDecl.dll, в которой содержится функция склонения. Ее можно взять на диске ИТС и, скопировав в папку с установленной платформой 1С – bin, зарегистрировать ее в операционной системе. Выполняется данная процедура при помощи команды resvr32 NameDecl.dll (под учетной записью администратора). Для этого необходимо вызвать команду «Выполнить» через кнопку «Пуск», воспользовавшись поиском или сочетание клавиш Windows + R.

Рис.1 Окно поиска. Поиск команды «Выполнить»

В появившемся окне вводим команду resvr32.exe и указываем путь к подключаемой библиотеке, используя кнопку «Обзор».

Рис.2 Окно команды «Выполнить»

После нажатия «Ок» появится сообщение о том, что библиотека успешно зарегистрирована.

Рис.3 Окно сообщения

Для данной библиотеки необходимо использовать 32-битную платформу 1С клиент-серверного режима.

Описание метода склонения в 1С

Просклонять (ФИО, Падеж, Пол) по параметрам:

  • ФИО (обязательный), тип – строка
  • Падеж (обязательный), тип – число

Падеж, в который необходимо поставить ФИО, задается числом от 1 до 6.

Таблица падежей: вопросы, предлоги и их значения в программном коде

Случается, возникает неоднозначная ситуация, когда программе необходимо определить принадлежность фамилии к полу, например, Сигида, Чепко, Сушко, Оганезян и т.д.

В этом случае используют дополнительный параметр:

  • Пол (необязательный), тип – число

Он показывает, склонять или не склонять фамилию. В других случаях этот параметр опускают или используют значение 0 («авто»), т.к. неправильное указание пола может повлиять на правильность склонения. Здесь возможные значения: 0 – авто, 1 – мужской, 2 – женский.

Сервис «Склонение по падежам»

В программах 1С 8.3 уже включен сервис для склонения данных сотрудников или контрагентов в соответствии с применяемыми в документе падежами.

Рис.4 Окно конфигуратора

Фрагмент 1

#Область ПрограммныйИнтерфейс // Склоняет ФИО // Только яля работы на ОС Windows. // // Параметры: // ФИО — Строка — Строка, в которой содержится ФИО для склонения. // Падеж — Число — падеж, в который необходимо просклонять представление объекта. // 1 — Именительный. // 2 — Родительный. // 3 — Дательный. // 4 — Винительный. // 5 — Творительный. // 6 — Предложный. // Объект — СбъехтСклонения — Ссылка на объект, реквизит которого склоняется // Пол — Число — Число — пол физического лида, // 1 — мужской, // 2 — женский. // // Возвращаемое значение: // Строка — Результат склонения ФИО в падеже. // Функция ПросклонятьФИО(ФИО, Падеж, Объект = Неопределемо, Пол = Неопределено) Экспорт // Склоняет представление объекта. Функция ПросклонятьПредставлекие(Представление, Падеж, Объект = Неопределено) Экспорт // Выполняет с формой действия, необходимые для подключения подсистемы Склонения.

Рис.5 Использование функции «Просклонять»

Фрагмент 2

// Склоняет представление объекта. Функция ПросклонятьПредставление(Представление, Падеж, Объект = Неопределено) Экспорт Возврат Просклонять(Представление, Падеж, Объект); Конецфункции // Выполняет с формой действия, не обходимые для подключения подсистемы Склонения Процедура ПриСозданииНаСервере(Форма, Представление, ИмяОсновногоРеквизитаФормы = «Объект») Экспорт // Обработчик события ПриЗаписиНаСервере управляемой формы объекта для склонения Процедура ПриЗаписиНаСервере(Форма, Представление, Объект, ЭтоФИО = Ложь, Пол = Неопределено) Экспорт // Устанавливает признак доступности сервиса склонения Процедура УстановитьДоступнсстьСервисаСклонения(Доступность) Экспорт УстановитьПривилегированныйРежим (Истина); ТекущиеПараметры = Новый Соответствие(ПараметрыСеанса.ПараметрыКлиентаНаСервере); ТекущиеПараметры.Вставить(«ДоступенСервисСклонения», Доступность); ПараметрыСеанса.ПараметрыКлиентаНаСервере = Новый ФиксированноеСсответствие(ТекущиеПараметры); УстановитьПривилегированныйРежим(Ложь); КонецПроцедуры

Используя в документе реквизиты, которые выбираются из справочника, в котором они представлены в именительном падеже, в печатную форму документа они будут выведены с нужным склонением.

Рассмотрим функцию склонения на примере договора в «1С:Бухгалтерия» 3.0. (1С:Предприятие 8.3). Здесь предусмотрено склонение ФИО и должности.

Рис.6 Окно формы договора. Настройка склонения фамилии и должности

В печатную форму программа автоматом поставит правильный вариант.

Рис.7 Окно программы – «Склонение по падежам»

Пример склонения по падежам можно видеть в «Приказе о приеме на работу». В карточке сотрудника его ФИО указано в Именительном падеже, а в печатной форме – в Родительном.

Рис.8 Пример склонения ФИО в печатной форме «Приказ о приеме на работу»

Программа 1С, учитывая требования законодательства и стандартов, позволяет соответствовать утвержденному порядку оформления документации и формирования печатных форм.

Склонение по падежам обусловлено и стандартами делового оборота, которые предусматривают, что любой документ должен быть оформлен не только грамотно, но и эстетически грамотно, что отражает статус организации.

Помимо этого использование таких функций в программе, как автосклонение, значительно снижает вероятность ошибок в составлении документов.